Announcement

Collapse
No announcement yet.

Yellow IS200

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 150mm pulley is on. Torque app is reading only 3.3psi so something ain't quite right, but I haven't yet stuck injectors in so haven't been booting it. I suspect a boost leak, so my weekend will consist of chucking the injectors and new spark plugs in and going through my pipework joint by joint.

    Apart from that exciting piece of news, I haven't done anything except sort out a sticky caliper and replace my warped front disks. So my headlights are still spazzy and my bumper still isn't sitting right. One of these weekends I'll sort it, maybe.

    Comment


    • Maybe have to have a look at JAE mate sort this bumper out!
      OutlawJapClub Admin Team

      Comment


      • Whats wrong with your headlights mate?


        Sent from my iPhone using Tapatalk

        Comment


        • Tabs are worn out so the lights ain't quite holding themselves in the correct position. I've got a better set if lights I just need to open email up and stick me halos in

          Comment


          • Did you fix the leak?
            OutlawJapClub Admin Team

            Comment


            • Sorry to revive an old thread but Iíve just read through the build (great car btw) I just wondered where you got your 1zzfe injectors from? Iím in desperate need of some myself for my pulley upgrade (145mm)
              Let me know if you can, Thanks.

              Comment

              Working...
              X